1) git; 2) golang 1.14+; 3) shell tools curl and jq; 4) building tools; 5) key-value storage library LevelDB.

Supported operating systems list (on 3 February, 2022):

  • Linux CentOS 7
  • Linux CentOS 8
  • Linux Ubuntu 16.04
  • Linux Ubuntu 18.04
  • Linux Ubuntu 20.04
  • Linux Ubuntu 22.04
  • Linux Debian 9
  • Linux Debian 10

If there is no your operating system in the list please get in touch with support team via https://decimalchain.com/

Hardware minimal requirements:

4 core CPU, 8 Gb RAM, SSD NVM 500Gb

To install building tools (which include make) and LevelDB use following commands:

RHEL 8 / CentOS 8:

sudo dnf groupinstall "Development Tools" sudo dnf install leveldb leveldb-devel snappy

Ubuntu:

sudo apt-get install build-essential sudo apt-get install libsnappy-dev libleveldb-dev

macOS:

brew install coreutils brew install leveldb snappy